Sent Apr 10, 2014

Heartbleed Security Update

As you might have heard there's been some major issues on the interwebz regarding something called Heartbleed. We just wanted to let you know that we did not use the OpenSSL 1.0.1 which was vulnerable, our servers was not affected by this issue. We did however update the OpenSSL to the latest version yesterday (8th of April) so you are all safe anyhow.

Let us know if you have any questions.